Andrey Hihlovskiy

Professional blog on groovy, gradle, Java, Javascript and other stuff.

Change in JDK 1.7.0_25 breaks all grails applications

Change in JDK 1.7.0_25 breaks all grails applications:
https://bugzilla.redhat.com/show_bug.cgi?id=976693
I just tried grails 2.2.3 – the problem is still not fixed, the application fails to start with an error message “Could not determine Hibernate dialect for database name [H2]”
Any workarounds suggesting to replace hibernate libraries don’t work.
The following additional parameter allows to start grails:

grails -noreloading run-app

But hey, it’s no fun to start in no-reloading mode! Oracle, but things back!

Advertisements

3 responses to “Change in JDK 1.7.0_25 breaks all grails applications

  1. Angel Ruiz (@aruizca) August 15, 2013 at 05:06

    I am sorry mate, but I have several apps in Grails 2.2.3 and 2.2.4 running on JDK_1.7.0_25-b17 64bit in windows and 32 bit in linux with no problems whatsoever

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: